Mise à jour 2.4

Kratos

4,294 views

Romstation passe en version 2.4 !

 

Il s'agit principalement d'une mise à jour de maintenance qui vient corriger quelques bugs identifiés et améliorer les performances du navigateur intégré. L'interface générale a également été légèrement révisée.

 

Si vous possédez une version antérieure à l’actuelle 2.4, elle sera automatiquement mise à jour lors de votre prochain démarrage de l'application.

 

Note de version :

 

  • Correction d'un bug dans l’interprétation des paramètres d'exécution empêchant le lancement de certains jeux.
  • Correction d'un bug dans les filtres de recherche de jeux pouvant dupliquer les résultats.
  • Correction d'un bug provocant la déconnexion des comptes sur l'application.
  • En mode Multijoueur, correction d'un bug indiquant par erreur que "le serveur n'existe plus".
  • En mode Multijoueur, la fenêtre de progression du téléchargement automatique des jeux n'est plus modale/bloquante.
  • Nombreux correctifs apportés au navigateur intégré, améliorant sa stabilité et ses performances.
  • Le cache des jeux décompressés est maintenant automatiquement purgé après 30 jours d'inactivité.
  • Amélioration significative de la vitesse de chargement des onglets.
  • Modifications diverses de l'interface générale.


27 Comments


Recommended Comments



Bonsoir :)

 

Quand j'essaye de faire la mise à jour j'ai ce message qui s'affiche :

 

Capture d’écran (3).png

Share this comment


Link to comment
à l’instant, Clarence a dit :

Je vous conseil de refaire une install de zéro

 

1. Renommer le rép C:\RomStation en C:\RomStation.old

2. Installer RomStation dans C:\RomStation, ne le lancez pas

3. Déplacer les rep suivant

  • C:\RomStation.old\app\database
  • C:\RomStation.old\app\emulators
  • C:\RomStation.old\app\games

Vers

  • C:\RomStation\app\database
  • C:\RomStation\app\emulators
  • C:\RomStation\app\games

4. Lancer RomStation

 

Vous conserverez vos jeux, émulateurs et bien sur sauvegardes.

 

 

Share this comment


Link to comment

Problème avec les filtres. Si on coche 2 machines en même temps les jeux ne s'affichent plus. Exemple :

-> Vous cochez Playstation, vous avez vos jeux Playstation qui s'affichent

-> Vous cochez Playstation 2, vous avez vos jeux Playstation 2 qui s'affichent

-> Vous cochez Playstation et Playstation 2, plus rien de s'affiche.

Edited by cheitg

Share this comment


Link to comment

Salut,

 

Merci pour la mise à jour, l'interface est bien mieux mais j'ai un souci, depuis la MaJ le navigateur internet de RomStation n’arrête pas de faire crashes. pendant un bon moment d'utilisation le navigateur s’arrête de fonctionner et il devient tout vide, en ce moment la seul chose que je peux faire c'est de redémarrer RomStation .

 

Révélation

Screenshot_612.thumb.png.9bb09fb1f4a748ad19ca8094bd778bdd.png

 

Share this comment


Link to comment

@GambierBae Tu peux me dire si tu as le même problème quand tu sélectionnes le mode de rendu logiciel pour le navigateur ?

Share this comment


Link to comment
Il y a 6 heures, Ryukan a dit :

@GambierBae Tu peux me dire si tu as le même problème quand tu sélectionnes le mode de rendu logiciel pour le navigateur ?

 

Hello Ryukan

 

Juste pour te dire que j'ai le même souci que Gambier après une longue période d'hibernation de la fenêtre du logiciel , le navigateur plante , obligé de redémarrer

Pour répondre à ta question , Je l'utilise en mode logiciel et non matériel (A cause de problème de résolution ou je ne peux pas valider certaines choses dans le menu d'édition des fiches de jeu) et le soucis est présent quand même chez moi

Share this comment


Link to comment
Il y a 7 heures, Ryukan a dit :

@GambierBae Tu peux me dire si tu as le même problème quand tu sélectionnes le mode de rendu logiciel pour le navigateur ?

J'utilisais le navigateur en mode de rendu Matériel, je viens de le mettre en mode Logiciel pour voir si ça vas résoudre le problème.

Share this comment


Link to comment

Bonjour,

Depuis la mise a jour, je n'arrive plus a lancer les jeux 😞
J'ai retelechargé Romstation, mais le problème persiste.
Lorsque j'appuie sur "lancer" (pour n'importe quel jeux/émulateur) rien ne se passe.

Avez vous une idée du pourquoi et une solution?
Merci d'avance! 🙂

Share this comment


Link to comment

on pourra dans la prochaine mise a jour avoir les jeux Nintendo 64 en multijoueur (mode automatique)  

Share this comment


Link to comment

1458919318_RomStation2.4.thumb.png.1ccb2822aa0528f5bcd5b5e0b1f9c5b9.png

 

Lorsque l'on veut ajouter manuellement un jeu, certains bouton Parcourir (petit dossier)  ne fonctionne plus. 

Cela devient donc IMPOSSIBLE d'ajouter des jeux dans de bonnes conditions (il faut aller dans l'explorateur chercher le chemin du jeu, le copier, revenir dans romstation pour le coller, ajouter l'antislash, retourner dans l'explorateur pour faire renommer sur le nom du jeu pour le copier, puis retourner dans romstation pour le coller après le chemin).

 

Edited by cheitg

Share this comment


Link to comment

Hi

 

J'ai trouvé un nouveau problème que vous pourrez corrigé

Quand je sors mon ordi de veille , mon RS est encore ouvert , si je veux faire un upload , je choisis mon fichier , calcul du checksum et le formulaire ne se lancera point

Obligé de redémarrer RS après une veille du PC

Share this comment


Link to comment

Bonjour à tous 

J'ai le même problème que cheitg 

Problème avec les filtres. Si on coche 2 machines en même temps les jeux ne s'affichent plus. Exemple :

-> Vous cochez Playstation, vous avez vos jeux Playstation qui s'affichent

-> Vous cochez Playstation 2, vous avez vos jeux Playstation 2 qui s'affichent

-> Vous cochez Playstation et Playstation 2, plus rien de s'affiche

 

Share this comment


Link to comment

 

Le 07/03/2021 à 21:50, GambierBae a dit :

Salut,

 

Merci pour la mise à jour, l'interface est bien mieux mais j'ai un souci, depuis la MaJ le navigateur internet de RomStation n’arrête pas de faire crashes. pendant un bon moment d'utilisation le navigateur s’arrête de fonctionner et il devient tout vide, en ce moment la seul chose que je peux faire c'est de redémarrer RomStation .

 

  Masquer le contenu

Screenshot_612.thumb.png.9bb09fb1f4a748ad19ca8094bd778bdd.png

 

 

Bonjour GambierBae,

J'ai eu le même soucis que toi, et j'ai réussis à résoudre ce problème en faisant :

 

( Sur le raccourci Romstation ) Clique droit > Propriétés > Compatibilité >  cocher la case : Exécuter ce programme en mode compatibilité pour :  > ( Dans le volet déroulant choisir ) Windows 8. 

Voila en espérant t'avoir aider en attendant que le problème soit résolu.

 

Bon jeu.

Edited by Aelmat

Share this comment


Link to comment

Bonjour, 

J'ai un bug un peu étrange :

J'ai paramétré l'application pour démarrer sur l'écran des jeux.

Seulement, j'ai quand même l'écran "online" qui se place par dessus.

Il y a quelque chose à faire ?

image.png

Share this comment


Link to comment

C'est un bug connu, tu peux le contourner en utilisant le mode de rendu logiciel pour le navigateur.

Share this comment


Link to comment

Bonsoir,

 

Cette mise à jour 2.4 est vraiment foireuse...

 

Il m'est IMPOSSIBLE de me connecter et donc de télécharger un jeu/émulateur !!!

Il m'est aussi IMPOSSIBLE de changer le répertoire des jeux/émulateurs ==> RIEN n'est sauvegarder !!!

J'ai aussi droit à un message d'erreur java:

 

Citation

java.lang.NullPointerException
    at org.romstation.application.a.c(BrowserEngine.java:65)
    at org.romstation.application.RomStation.stop(RomStation.java:147)
    at com.sun.javafx.application.LauncherImpl.lambda$launchApplication1$9(LauncherImpl.java:882)
    at com.sun.javafx.application.PlatformImpl.lambda$runAndWait$7(PlatformImpl.java:326)
    at com.sun.javafx.application.PlatformImpl.lambda$null$5(PlatformImpl.java:295)
    at java.security.AccessController.doPrivileged(Native Method)
    at com.sun.javafx.application.PlatformImpl.lambda$runLater$6(PlatformImpl.java:294)
    at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95)
    at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
    at com.sun.glass.ui.win.WinApplication.lambda$null$3(WinApplication.java:177)
    at java.lang.Thread.run(Thread.java:748)
 

 

Puis deux messages:

 

Citation

RomStation.exe

 

Error invoking method.

 

Et:

 

Citation

RomStation.exe

 

Failed to launch JVM

 

Je précise que je suis déjà avec la dernière version de Java et que j'ai totalement réinstaller l'application de zéro...

 

Une mise à jour qui introduit énormément de problèmes...

Share this comment


Link to comment

Hello, moi Romstation ne se lance qu'uniquement en mode administrateur, sinon plantage systématique 🙂 

Share this comment


Link to comment